Introduzione a BCG

BCG® è un generatore di codici a barre ad alte prestazioni che funziona sotto i sistemi operativi Microsoft® Windows® 9x, NT, ME, 2000 e XP.

Esso è in grado di produrre codici a barre nei più diffusi formati lineari:

  • EAN-8
  • EAN-13
  • UPC-A
  • UPC-E
  • Codice 39
  • Codice 93
  • Codice 128
  • Industrial
  • 5 barre
  • Matrix 3 barre
  • BCD matrix
  • MSI
  • Interleaved
  • Codabar/Monarch
  • EAN 128
  • Codice 32 (farmaceutico italiano)

Per lineare intendiamo un codice a barre come siamo normalmente abituati a vederlo: una serie alternata di linee dritte, bianche e nere, di diverso spessore.

Inoltre, BCG è in grado di produrre anche una circolarizzazione per ciascuna delle simbologie elencate. Un codice a barre circolare è leggibile dagli stessi strumenti riservati alla lettura dei codici a barre tradizionali, ma presenta alcuni vantaggi:

1. può essere letto qualunque sia l'orientamento del codice rispetto alla direttrice di lettura;
2. può essere utilizzato per etichettare supporti, quali cd-rom e DVD, che richiedono un perfetto bilanciamento dell'etichetta.

BCG è altamente configurabile, compatto e semplice da usare. Esso permette di creare da altri programmi la lista dei codici da stampare, di importarla e stamparla in background, senza necessità di intervento da parte dell'utente. Un comodo pannello di controllo offre funzioni avanzate di editing della lista dei codici da stampare e permette di modificare agevolmente tutti i principali parametri di funzionamento. Grazie alle funzioni di caricamento e salvataggio delle liste codici e della configurazione, è possibile utilizzare il generatore per produrre etichette di dimensioni e tipologie molto variabili. Oltre che su carta, i codici possono anche essere salvati su file in formato PCX/BMP e copiati nella clipboard di Windows, per poterli incollare in altre applicazioni.

Il posizionamento dei codici è facile e preciso; è possibile specificare se includere o meno il testo in chiaro e la cifra di controllo, indicare il tipo di font e le dimensioni per descrizione e codice in chiaro, l'interlinea e l'allineamento. Una comoda funzione di anteprima permette di visualizzare i dati nella lista codici, per poter stabilire ad esempio con che simbologia un codice campione è stato prodotto.

BCG, nella versione registrata, può essere protetto da:
1) una chiave software, dipendente dal computer di installazione;
2) un dongle hardware collegato ad una porta USB;
3) un dongle hardware collegato alla porta parallela numero uno (LPT1).

Quest'ultimo dispositivo è trasparente a tutti i dispositivi paralleli standard e anche a buona parte di quelli fuori-standard.

Nella versione non registrata, il programma presenta le seguenti limitazioni:
1) i codici sono sbarrati con una croce;
2) la stringa da codificare è una permutazione casuale del codice introdotto;
3) non è possibile stampare più di 40 codici;
4) il numero di copie è fissato ad 1;
5) è disabilitato il salvataggio ed il caricamento della configurazione/lista codici;
6) i pulsanti "Copia in clipboard" e "Salva anteprima" non hanno alcun effetto;
7) il pulsante "Stampa" o il comando File->Stampa non hanno effetto dopo cinque stampe;
8) ogni eventuale descrizione è sempre sostituita dalla scritta "Demo";
9) solo i primi 4 caratteri e l'ultimo carattere di ogni codice sono mantenuti; i rimanenti sono impostati a "0";
10) la modalità di avvio automatico è disabilitata.

BCG® - Bar Code Generator
© 2000-2009 Simone Zanella Productions
Tutti i diritti riservati.


Il pannello di controllo principale

L'immagine a lato mostra il pannello di controllo principale di BCG. La disposizione degli elementi prevede una fascia di menu con tre voci (File, Configura, ?), con una barra degli strumenti sottostante. Nella finestra di lavoro vera e propria trovano spazio 8 pulsanti surdimensionati, più due tasti freccia e 5 campi di testo. L'interazione con i vari strumenti della finestra è stata studiata per garantire la massima produttività e permettere di svolgere tutte le operazioni da tastiera, oltre che da mouse. Come in tutti i programmi per Windows, è possibile utilizzare la tabulazione per passare da un controllo al successivo, oppure digitare la lettera che si trova sottolineata nel nome dei vari comandi, in combinazione con il tasto Alt. Soffermando per qualche istante il cursore del mouse sopra ciascun controllo comparirà un breve testo descrittivo (tooltip) che illustra la sua funzione. Alcune icone della barra degli strumenti hanno due forme, in modo da evidenziare lo stato corrente dell'opzione. Le stesse icone presenti sulla barra sono duplicate anche accanto alle relative funzioni nei menu, per facilitarne la comprensione. La finestra presenta un'area sulla parte sinistra inizialmente bianca; essa è la lista dei codici da stampare, che dovrà essere progressivamente riempita servendosi dei tasti Inserisci e Accoda, introducendo l'intervallo dei codici da stampare attraverso i campi Codice iniziale e Codice finale. Il campo Incremento permette di specificare il valore che deve essere progressivamente addizionato al Codice Iniziale per raggiungere il Codice Finale (ad es. 10, se si vuole mantenere fissa l'ultima cifra per tutti i codici introdotti; può anche essere negativo).

La casella contraddistinta da una grande X posta alla sua sinistra serve a ripetere più volte ciascun codice introdotto; detto n il numero presente in questa casella, quando si preme il pulsante Inserisci oppure Accoda i codici inseriti nella lista saranno duplicati ciascuno n volte. Il valore di questa casella ritorna ad 1 ad ogni avvio del programma.

Il campo Descrizione permette di introdurre un testo da stampare assieme a ciascun codice a barre nell'intervallo; la combinazione di caratteri "%%" viene rimpiazzata dinamicamente, quando si aggiunge la sequenza, dal HRC di ciascun codice; in questo modo, è possibile riposizionare a piacere il codice in caratteri leggibili. Se si vuole introdurre una descrizione multiriga, utilizzare il carattere divisore di riga configurato in layout.

Se la simbologia utilizzata è EAN 128, accanto al Codice Iniziale compare una bacchetta magica: clickando con il mouse su di esso si aprirà un assistente (wizard) per facilitare la composizione del codice a barre secondo le specifiche Indicod.

La funzione svolta da ciascuno degli altri elementi è la seguente:

Dopo aver introdotto il codice iniziale e finale, premendo questo tasto i codici nell'intervallo sono introdotti nella lista dei codici da stampare, prima dell'elemento attualmente selezionato. Se nessun elemento è selezionato, questo pulsante è funzionalmente equivalente al pulsante Accoda. Premendo il tasto Invio quando il controllo attivo è il campo Codice Iniziale o il campo Codice Finale viene automaticamente azionato questo pulsante.

Questo pulsante opera come il pulsante Inserisci: l'unica differenza è che i codici sono aggiunti alla fine della lista, indipendentemente dall'elemento selezionato nella lista.

Questo pulsante rimuove i codici selezionati dallalista. Tale lista ammette la selezione estesa di Windows: mantenendo premuto il tasto Ctrl è possibile selezionare codici non contigui; mantenendo premuto il tasto sinistro del mouse durante il trascinamento, verranno selezionati tutti i codici compresi nella traiettoria attraversata.

Di norma, tutti i codici sono stampati consecutivamente, in base alle impostazioni del layout. Con questo controllo è possibile inserire una etichetta bianca, ad esempio per stampare su un foglio parzialmente utilizzato. L'etichetta è inserita prima dell'elemento attualmente selezionato nella lista, oppure in fondo ad essa se non esiste una selezione corrente.

Con i primi due pulsanti è possibile spostare rispettivamente verso l'alto o verso il basso la selezione corrente nella lista, per riordinare la sequenza dei codici stampati. Il terzo pulsante inverte completamente l'ordine della lista (il primo codice diventa l'ultimo e viceversa)

In ogni caso, lo spostamento o la rimozione dei codici comportano l'aggiornamento della relativa descrizione associata.

E' possibile stampare un logo al centro del codice (circolare, quadrilineare, semicirconferenze); è sufficiente salvare nella stessa cartella del programma un file denominato "LOGO.BMP"; il programma provvederà a scalarlo e a stamparlo su ciascuna etichetta del tipo indicato.

Questo pulsante copia il contenuto dell'anteprima nella clipboard di Windows. Il numero di colori dell'immagine rispecchia la modalità video corrente*.

Questo pulsante salva il contenuto dell'anteprima in un file selezionato dall'utente. Il formato grafico utilizzato è il PCX monocromatico (che permette il raggiungimento di un buon livello di compressione) oppure il formato bitmap di Windows*. Nel nome del file, nel caso di stampa automatica, specificare il carattere "%" come segnaposto per il contenuto del codice (BCG aggiunge automaticamente il carattere "%" in coda, se l'utente non lo ha specificato).

* I codici visualizzati nell'anteprima di stampa sono solo lineari o circolari; eventuali codici divisi in semicirconferenze o quadrilineari possono solo essere stampati.

Premendo questo pulsante, il programma stampa il numero di copie indicato nella casella Copie soprastante dei codici nella lista. Le copie non sono fascicolate, cioè ogni pagina intera è ripetuta per il numero di volte indicato.

La barra degli strumenti svolge le medesime funzioni ottenibili dai menu File, Configura e ?. L'elenco delle funzioni è riassunto di seguito:

Azzera lista

Carica lista

Salva lista

Stampa

Stampante

Layout

Codici a barre

File dati

Avvio automatico

Anteprima


Il pannello configura stampante

Con questo pannello è possibile configurare il dispositivo di Windows che verrà utilizzato per produrre i codici e l'orientamento di stampa. Selezionare dalla lista drop-down la stampante prescelta e indicare la direzione di stampa; premere il pulsante "..." per configurare le proprietà del dispositivo. Nel caso di stampa verticale, le righe di codici sono parallele al lato corto del foglio; nel caso di stampa orizzontale, sono parallele al lato lungo.

Per accedere a questo pannello, selezionare la voce di menu Configura->Stampante oppure utilizzare il pulsante [image].


Il pannello configura layout

Con questo pannello è possibile configurare la posizione e le distanze per i codici da stampare, oltre ai font per il testo ed al relativo allineamento.

Le coordinate X ed Y indicano la posizione dell'angolo superiore sinistro della codifica a barre per il primo codice da stampare; le ascisse si misurano a partire dal lato sinistro del foglio, le ordinate dal margine superiore. Si tenga presente che il valore introdotto in queste caselle è misurato a partire dal primo punto stampabile dell'angolo superiore sinistro del foglio, il quale si trova ben dentro l'area del foglio, dal momento che tutte le stampanti hanno un margine non stampabile che oscilla dai 5 ai 10 mm.

I valori H e V indicano, rispettivamente, la distanza orizzontale e verticale che intercorre tra le codifiche a barre di due codici adiacenti (sulla stessa riga o sulla stessa colonna).

La cornice Font incasella le informazioni relative al testo stampato; utilizzando ipulsanti radio Descrizione e Codifica in chiaro cambieranno le informazioni contenute nella cornice, a riflettere quale parte del codice stiamo considerando (la rappresentazione testuale del codice a barre oppure una descrizione posta sopra di esso). In particolare, con il pulsante Cambia è possibile selezionare il font e le rispettive caratteristiche del testo (dimensione in punti, grassetto, corsivo, sottolineato).

I pulsanti radio Allineamento permettono di allineare l'HRC (Human Readable Characters) a sinistra, al centro o a destra della codifica a barre. La distanza dal codice viene misurata dal basso per l'HRC e dall'alto per la descrizione. Proprio per la descrizione, abbiamo due campi supplementari:

1. Interlinea
2. Divisore riga

L'interlinea indica di quanto avanzare, rispetto all'altezza della cella dei caratteri, al completamento di ogni riga. La misura è data in percentuale.

Il carattere divisore di riga permette di introdurre ledescrizioni associate ai codici sotto forma di un'unica stringa, che verrà poi suddivisa ad ogni occorrenza del carattere introdotto.

Il numero di etichette per riga e per colonna completa le informazioni necessarie a specificare il layout che si desidera ottenere.

Per accedere a questo pannello, selezionare la voce di menu Configura->Layout oppure utilizzare il pulsante [image].


pannello configurazione codici a barre; simbologia; barra, stretta; barra, larga; sbordamento; differenza bianca; risoluzione; hrc; codice, in caratteri leggibili; cifra di controllo; check digit; overflow, interno; altezza barre; codice, a specchio

Il pannello configura codici a barre

Con questo pannello è possibile configurare la simbologia e le caratteristiche peculiari dei codici che si andranno a stampare. Modificando la simbologia, saranno automaticamente filtrati dalla lista codici tutti i codici divenuti inammissibili (ad esempio, perché contengono dei caratteri non codificabili).

Le impostazioni relative a: simbologia; barra stretta; barra larga; differenza bianca; sbordamento; check digit sono sempre relative alla selezione corrente del tipo di codice (circolare o lineare); nel caso in cui si stampino codici ibridi (opzioni "Dividi in semicirconferenze" e "Integra con codice lineare" selezionate) le due parti del codice saranno stampate rispettivamente con le impostazioni selezionate.

Per una rapida configurazione dei parametri secondo un particolare tipo di codice, è possibile utilizzare la funzione Quick Set e selezionare il modello desiderato.

Gli elementi configurabili sono i seguenti:

1. la Simbologia rappresenta il metodo con cui le informazioni saranno trasformate in codici a barre; esistono numerosi modelli di codifica, che sono approfonditi qui;

2. ogni codice a barre è prodotto dalla successione di barre strette e larghe, bianche o nere; le caselle Barra stretta e Barra larga permettono di indicare i rispettivi valori. La barra larga dovrebbe essere sempre un multiplo della barra stretta;

3. la differenza bianca è il numero di pixel che andrà aggiunto ad ogni barra stretta bianca, per compensare eventuali sbordamenti dell'inchiostro; generalmente, è possibile impostare a zero questo campo se si utilizzano stampanti laser;

4. lo sbordamento serve, come la differenza bianca, a compensare diffusioni dell'inchiostro in stampa; per stampanti a getto d'inchiostro, è possibile impostare a 1 o 2 questo valore, e lasciarlo a zero per l'utilizzo con le stampanti laser; ovviamente, l'impostazione di una differenza bianca e/o di uno sbordamento aumentano le dimensioni dei codici prodotti;

5. l'espansione nero è un valore aggiunto ad ogni circonferenza interna, per evitare pixel bianchi all'interno delle barre larghe;

6. la risoluzione è utilizzata per la stampa su carta, ma anche e soprattutto per determinare la dimensione dei file prodotti dall'anteprima di stampa e per salvare di conseguenza questo dato nella generazione dei file grafici da codici;

7. il codice in caratteri leggibili è una casella di spunta, che permette di indicare se il codice a barre deve essere muto oppure parlante;

8. la cifra di controllo (o check digit) permette di aggiungere automaticamente, ad ogni codice stampato, una o più cifre di controllo, che aumentano la sicurezza della rilevazione; andrebbe sempre abilitato se possibile, sebbene in questo modo i codici divengano più lunghi;

9. la casella di spunta Includi cifra di controllo in HRC permette di specificare se nella parte parlante del codice debba essere riportata la cifra di controllo; di default, non andrebbe inclusa, anche perché la maggior parte di dispositivi in commercio prevedonol'eliminazione della cifra di controllo dal codice restituito (no check recording);

10. la casella di spunta HRC radiale permette, nei codici a barre circolari, di stampare il contenuto in chiaro al posto di un raggio; il codice resta comunque leggibile qualunque sia l'orientamento del raggio di lettura, in quanto metà del diametro contiene già tutta l'informazione codificata;

11. la casella di spunta HRC centrale permette, nei codici a barre circolari, di stampare il contenuto in chiaro al centro della prima circonferenza;

12. selezionando il pulsante radio Codice circolare è possibile specificare l'overflow interno, cioè la larghezza del primo raggio dell'area del codice, e la copertura quadrante, cioè l'estensione delle circonferenze tracciate; nel caso di etichettatura di DVD e CD, l'overflow corrisponde ad 8 mm; tracciando un numero di quadranti inferiore la stampa viene velocizzata - teoricamente, due quadranti assicurano una copertura più che sufficiente per una lettura omnidirezionale;

13. selezionando il pulsante radio Codice lineare è possibile specificare l'altezza delle barre, cioè l'altezza della codifica a barre all'atto della stampa;

14. la casella di spunta Codice a specchio permette di rovesciare la sequenza delle barre, come se l'immagine fosse vista allo specchio.

L'opzione "Integra con codice lineare" permette di stampare un codice lineare con l'informazione complessiva insieme al codice suddiviso in due semicirconferenze, ad uso (per esempio) di un lettore manuale.

L'opzione "Codice quadrilineare" (mutuamente esclusiva con l'opzione "Dividi in semicirconferenze") permette di stampare lo stesso codice lineare nelle quattro direzioni, attorno alla circonferenza individuata dall'overflow interno. In questo caso, se si attiva la stampa dell'HRC questo sarà riportato solo per il codice orizzontale stampato nella parte bassa dell'etichetta; l'altezza delle barre per questo particolare codice si imposta nella casella "Altezza barcode con HRC".

L'opzione "Secondo codice lineare" permette di stampare un codice lineare accanto ad un codice circolare, semicircolare o quadrilineare; il codice lineare segue le relative impostazioni del pannello di controllo, ma è possibile specificare un'altezza diversa e uno spostamento orizzontale e verticale dal codice circolare oppure dall'altro codice lineare.


Suggerimenti sulla stampa di codici circolari

I codici a barre circolari prodotti da BCG rappresentano una circolarizzazione dei codici a barre lineari che si vedono comunemente; laddove questi ultimi presentano linee verticali, un codice a barre circolari presenta una circonferenza, ovviamente di pari spessore. In questo modo, la figura che si viene a creare appare come un bersaglio, in cui ogni raggio contiene la stessa informazione del codice a barre lineare equivalente.

Il vantaggio di questo sistema consiste nella possibilità di avere un simbolo perfettamente simmetrico, che può essere letto in maniera più semplice rispetto ad un codice tradizionale, soprattutto nel caso in cui l'oggetto da etichettare sia circolare, come un compact disc oppure un dvd. Infatti, è sufficiente che il raggio di lettura intersechi il simbolo in una qualsiasi direzione per ottenere la lettura del codice. Inoltre, questo tipo di codice può avere un foro al centro e permette di etichettare, quindi, anche supporti in cui è di importanza critica mantenere equilibrato l'oggetto dopo l'etichettatura.

Come per i codici lineari, è necessario prestare attenzione ad alcune regole elementari. Una di queste è il lasciare sempre sufficiente spazio bianco all'interno della prima circonferenza e subito dopo l'ultima. Questa zona è nota, nei codici lineari, come overflow. Una zona di overflow troppo limitata può rendere difficoltosa la lettura del codice. Inoltre, un overflow centrale di maggiori dimensioni rende più semplice la centratura del codice, permettendo un certo lasco nell'attraversamento del raggio di lettura.

Uno degli svantaggi nell'utilizzo di questo tipo di codici consiste nella superficie maggiore richiesta dal simbolo; per minimizzarla, è necessario aumentare la risoluzione delle barre, diminuendone la dimensione. Per questo è necessario dotarsi di sistemi di stampa e di lettura che siano in grado di supportare questa risoluzione. Prima di stampare grosse quantità di codici, è opportuno fare svariate prove, a varie risoluzioni, in modo da essere certi che il codice risulti leggibile in tutte le condizioni (anche considerando il tipo di usura a cui il simbolo sarà soggetto). Il miglior tipo di dispositivo di stampa per la realizzazione di questi codici è una stampante laser; tuttavia, è possibile utilizzare anche stampanti a getto d'inchiostro o a trasferimento termico, purché, in questo caso, si regolino opportunamente i valori di sbordamento e differenza bianca. Di norma, il valore che è preferibile modificare in questi casi è lo sbordamento, che agisce sulla dimensione delle aree bianche nel loro complesso e non sul singolo elemento stretto bianco.

Nel caso in cui l'etichetta debba essere letta da uno scanner industriale, la stampa del codice suddiviso in semicirconferenze può permettere di abbassare la risoluzione di stampa, mantenendobuone prestazioni. In questo caso, si raccomanda di utilizzare come simbologia l'Interleaved 2/5 senza check digit ma con prefissi distinti per la prima e seconda semicirconferenza. Infatti, il firmware di molti scanner industriali permette di unire i due codici rilevati e di determinarne la sequenza in base alla corrispondenza del primo carattere. Se lo stesso codice deve essere letto anche da lettori manuali, l'aggiunta del codice lineare (disponibile come opzione) permette di mantenere la compatibilità del codice prodotto con questi lettori.


Suggerimenti sulla stampa di codici lineari

I codici a barre lineari sono costituiti da una successione di barre e spazi che contengono l'informazione codificata in modo binario: 1-0.
L'informazione può essere codificata utilizzando o solo le barre o anche gli spazi.
Si definisce simbolo o etichetta in codice a barre l'insieme degli elementi.
Elementi o moduli del codice sono le barre e gli spazi che lo costituiscono.

Questo insieme può essere diviso in sottoinsiemi che presentano proprie caratteristiche:

1. elementi del codice in cui sono codificate le informazioni (caratteri);
2. elementi di controllo: barre di guardia (start-stop-centro), spazi di separazione (intercarattere);
3. zona di overflow: zona bianca o di rispetto, che precede e segue la sequenza di barre nere.

Quest'ultimo spazio deve essere lasciato libero da ogni scritta per consentire ai decodificatori il corretto riconoscimento delle caratteristiche barre di guardia di inizio e fine codice (start-stop). La larghezza è circa 10 volte quella dell'elemento stretto, con un minimo di 2.5 mm per i codici ad altissima risoluzione.

I codici lineari stampati da BCG sono di tipo bidimensionale, in quanto la stessa informazione si ripete per tutta l'altezza del simbolo.

Qualora si vada a stampare su supporti colorati, è necessario prestare attenzione al contrasto tra barre nere e spazi, in quanto un contrasto insufficiente può determinare l'illegibilità del simbolo da parte di molti dispositivi. Il contrasto è definito come il rapporto tra la riflettenza degli elementi scuri (barre) e gli elementi chiari (spazi) del simbolo. Se i codici stampati debbono essere letti a distanze elevate (1.5-2 metri), è necessario abbassare considerevolmente la risoluzione e, possibilmente, utilizzare un tipo di supporto speciale, ad alta riflettenza.

Prima di stampare grosse quantità di codici, è opportuno fare svariate prove, a varie risoluzioni, in modo da essere certi che il codice risulti leggibile in tutte le condizioni (anche considerando il tipo di usura a cui il simbolo sarà soggetto). Il miglior tipo di dispositivo di stampa è una stampante laser; tuttavia, è possibile utilizzare anche stampanti a getto d'inchiostro o a trasferimento termico, purché, in questo caso, si regolino opportunamente i valori di sbordamento e differenza bianca. Di norma, il valore che è preferibile modificare in questi casi è lo sbordamento, che agisce sulla dimensione delle aree bianche nel loro complesso e non sul singolo elemento stretto bianco.

In ogni caso, qualora sia possibile, includere sempre l'HRC (human readable code), cioè la versione in caratteri leggibili del contenuto del codice a barre, in quanto è possibile che una deformazione nella carta o nella stampa rendano il codice illeggibile.

Nel caso di etichettatura di supporti come CD o DVD è possibile utilizzare codici circolari oppure la modalità quadrilineare, che permette di ottenere uno stesso codice lineare distribuito nelle quattro direzioni attorno ad una circonferenza.


Come scegliere la simbologia adatta

Si definisce simbologia il modello di codifica delle informazioni in codici a barre. Esistono numerose simbologie diverse, e quelle più diffuse ed utilizzate sono implementate in BCG.

Perché esistono così tanti sistemi di codifica?

Il motivo risiede nelle diverse esigenze manifestate dalle industrie che poi hanno utilizzato i codici a barre. Infatti, le necessità possono essere classificate in base a diversi criteri:

1. la ridotta dimensione dei codici da stampare;
2. i caratteri che andranno codificati (solo cifre, oppure anche lettere);
3. la tolleranza dei codici a sistemi di stampa non troppo precisi;
4. la facilità con cui questi codici sono riconosciuti dai decodificatori;
5. la sicurezza nella decodifica del contenuto rappresentato.

Le simbologie maggiormente utilizzate oggi sono la codifica EAN/UPC, il codice 39, il codice 128 ed il codice 93.

La famiglia delle codifiche EAN/UPC è frutto di uno sforzo di standardizzazione per catalogare le merci destinate alla rivendita. Nella sua versione più diffusa (EAN 13), essa permette di codificare 12 cifre numeriche più 1 cifra di controllo (check digit). Nell'uso più comune, è possibile utilizzare sia i codici sui prodotti provenienti dall'esterno, che propri codici generati in-store, grazie al fatto che la specifica ha riservato tutti i codici che iniziano con le cifre dal 20 al 29 all'uso interno. In questo modo, qualsiasi simbolo che inizia con queste cifre non potrà mai provenire da un produttore esterno.

Questo tipo di codici è solo numerico, continuo, self-checking ed è caratterizzato da un'alta densità di informazione. Per contro, ha un numero di cifre fisso e 4 livelli di spessori degli elementi, che rendono necessaria un'elevata precisione in stampa. La presenza della cifra di controllo garantisce un'ottima sicurezza del dato rilevato.

Una variante dell'EAN 13 è la simbologia EAN 8, nata per sostituire l'EAN 13 nelle applicazioni in cui tale simbolo risulta di dimensioni troppo grandi rispetto all'oggetto da etichettare. L'EAN 8 permette di codificare 7 cifre più 1 cifra di controllo; è la simbologia che raccomandiamo per la realizzazione di codici a barre circolari destinati ad etichettare compact disc e dvd.

Il codice 39 è probabilmente la simbologia più diffusa del mondo; essa prevede una identica sequenza di start e di stop ed elementi di due soli spessori (stretto e largo).I caratteri codificabili includono le 10 cifre, i 26 caratteri dell'alfabeto ed i caratteri speciali spazio, meno, punto, /, + e %; è anche possibile utilizzare una cifra di controllo, sebbene la maggior parte dei simboli codificati con questa simbologia ne siano sprovvisti.

I vantaggi di questo tipo di simbologia sono la sua grande diffusione, la buona tolleranza, la lunghezza variabile e la possibilità di codificare lettere, oltre che numeri; per contro, la densità di informazione è molto bassa.

Il codice 93 nasce come evoluzione del codice 39; esso permette di codificare i medesimi caratteri, ma ha una densità di informazione decisamente superiore, avendo 4 possibili spessori degli elementi. Esso, inoltre, viene normalmente utilizzato con check digit, rappresentato da due caratteri, per cui garantisce un'ottima sicurezza nella decodifica. I vantaggi di questa simbologia sono l'alfanumericità, la lunghezza variabile, l'alta densità di informazione; per contro, i quattro diversi spessori degli elementi richiedono una buona precisione in stampa. Se i propri strumenti di lettura lo supportano, è senza dubbio un'ottima scelta.

Il codice 128 permette di rappresentare tutti i 128 caratteri ASCII; è un codice compatto, con alta densità di informazione, per lo più utilizzato con una cifra di controllo. Si tratta di una delle simbologie oggi più utilizzate, grazie alla sua versatilità e compattezza. A differenza degli altri codici presentati, la sua lunghezza può variare a seconda della sequenza da codificare, anche se rappresentata dal medesimo numero di caratteri. Infatti, viene applicata una serie di regole per minimizzarne la lunghezza, ed in particolare cifre numeriche consecutive sono rappresentate a coppie, raddoppiando la densità ottenibile con soli caratteri alfabetici.


Menu File

Carica lista

Salva lista

Azzera lista

Stampa

Esci

Selezionare una delle voci di menu soprastanti per ottenere informazioni sulla relativa funzionalità.


Menu Configura

Stampante

Layout

Codici a barre

File dati

Avvio automatico

Anteprima

Selezionare una delle voci di menu soprastanti per ottenere informazioni sulla relativa funzionalità.


Menu Aiuto

Aiuto

Informazioni

Registra/Info Registrazione

Selezionare una delle voci di menu soprastanti per ottenere informazioni sulla relativa funzionalità.


Aiuto

Questo comando richiama la guida che state leggendo.


Anteprima

Utilizzare questo comando per impostare o meno l'anteprima; lo stato corrente dell'opzione sarà riflettuto dall'icona accanto alla voce del menu e dal pulsante [image] nella barra degli strumenti. Se l'opzione è disattivata, compare sovrapposto un cerchio rosso sbarrato. Ad opzione attivata, il pannello di controllo principale si allarga ad includere una finestra nella quale verrà visualizzato il codice della lista attualmente evidenziato, e saranno resi disponibili i tasti per copiare nella clipboard il codice e per salvare l'immagine in un file grafico.


Avvio automatico

Utilizzare questo comando per impostare o meno la modalità automatica; lo stato corrente dell'opzione sarà riflettuto dall'icona accanto alla voce del menu e dal pulsante [image] nella barra degli strumenti. Se l'opzione è disattivata, compare sovrapposto un cerchio rosso sbarrato. Per poter accedere nuovamente al pannello di controllo di BCG, eliminare il file dati impostato per la modalità automatica e lanciare il programma.

Quando la modalità automatica è impostata, all'avvio BCG resta minimizzato ad icona nella traybar, carica la lista dei codici, la stampa ed esce; il pannello di controllo compare nuovamente solo quando il file lista non viene più trovato.


Azzera lista

Utilizzare questo comando per azzerare la lista dei codici e le rispettive descrizioni.

Il comando non è reversibile.


Carica lista

Utilizzare questo comando per importare una lista di codici e/o una configurazione, precedentemente salvata dallo stesso BCG, oppure creata da un altro programma. I file salvati da BCG, infatti, sono visualizzabili ed editabili attraverso un editor di testo, come Notepad di Windows. Il metodo più rapido per ottenere le istruzioni necessarie a raggiungere una determinata configurazione consiste nel salvare una lista vuota di codici ed utilizzare il file così prodotto come riferimento.


Esci

Utilizzare questo comando per uscire, oppure clickare sul pulsante X in alto a destra, oppure ancora premere la combinazione di tasti Ctrl+X.


File dati

Con questa opzione è possibile impostare un file (in formato ".BCG") che il programma andrà a caricare e stampare subito dopo l'avvio, se la modalità automatica è inserita.

In questo modo, è possibile automatizzare il processo di stampa da altri applicativi: inserendo la modalità automatica e uscendo, al successivo avvio BCG caricherà e stamperà i codici trovati nel file, mostrando solo la sua icona nella traybar durante tale operazione ed uscendo subito dopo la fine della stampa. Si ponga attenzione ai valori di configurazione per il file dati e per l'avvio automatico impostati all'interno dello stesso file dati, altrimenti si potrebbe inavvertitamente disattivare questa funzione, con il risultato di non riuscire più a stampare in maniera automatica, se non re-impostando il parametro di configurazione. Per poter accedere nuovamente al pannello di controllo di BCG, eliminare il file impostato con questa opzione e lanciare il programma, disattivando quindi la modalità automatica. Questa opzione è accessibile anche attraverso il pulsante [image] della barra dei comandi.

Se BCG è invocato con uno o più parametri sulla linea di comando, viene attivata implicitamente la modalità automatica, sono caricate le configurazioni e stampati i codici come richiesto. In questo modo, è anche possibile redirigere l'uscita ad un file BMP/PCX o alla clipboard, aggiungendo le seguenti linee al file di configurazione (solo una delle due):

PXnomefile

CB

La prima linea dice a BCG di salvare l'uscita su "nomefile" (che deve avere estensione .BMP o .PCX), la seconda dice a BCG di copiare l'immagine risultante nella clipboard. Eventuali caratteri "%" presenti in "nomefile" saranno sostituiti all'atto della stampa dal numero del codice nella lista codici caricata, a partire da 0.


Registra/Info Registrazione

Questo comando mostra le informazioni di registrazione del prodotto (versione registrata con chiave software) oppure permette di generare una richiesta di registrazione (versione demo).


Informazioni

Questo comando mostra le informazioni sulla versione corrente, sull'autore del programma e sui copyright.


Salva lista

Utilizzare questo comando per salvare la lista di codici e/o la configurazione corrente. Il file prodotto, con estensione di default ".BCG", è un file di testo che contiene la sequenza di istruzione per re-impostare la configurazione e caricare nella lista i codici con le rispettive descrizioni.


Stampa

Utilizzare questo comando per stampare l'attuale lista dei codici. Questo comando è equivalente al pulsante:

e all'icona [image] nella toolbar.