Introduzione a Visual Pool Manager

Visual Pool Manager® è un applicativo specializzato per la gestione delle prenotazioni di una o più piscine, funzionante sotto i sistemi operativi Microsoft® Windows® 95/98/ME/NT/2000/XP/2003/Vista.

Con questo programma è possibile:

  • creare dei corsi scuola e suddividerli in turni sull'arco della settimana;
  • creare dei corsi ad iscrizione libera e gestire abbonamenti per essi;
  • registrare i dati anagrafici dei soci e gestire le iscrizioni ai corsi scuola ed al nuoto libero;
  • vendere ingressi singoli al nuoto libero;
  • monitorare gli ingressi alle vasche e le uscite, attraverso badge RF e tornelli automatici;
  • mantenere le informazioni rilevanti sulle vasche;
  • gestire un calendario di chiusura delle attività;
  • ottenere report a video e su carta relativi alle disponibilità e agli iscritti dei vari corsi;
  • monitorare i soci con attività o iscrizione scaduta ed i soci insolventi;
  • verificare i soci iscritti in un certo periodo;
  • ottenere un quadro delle quote incassate in un certo periodo e delle frequenze registrate.

Visual Pool Manager è un applicativo agile, veloce e semplice da usare, grazie ad una interfaccia grafica intuitiva e ad una organizzazione razionale delle funzioni. L'applicativo permette (a seconda del numero di licenze acquistate) l'utilizzo in rete e la condivisione dei dati in tempo reale per un massimo di 30 utenti; in questo caso, solo una postazione (denominata primaria) può svolgere determinate funzioni a carattere amministrativo.

Per la comprensione del resto del manuale è necessario definire alcuni concetti:

socio

è un fruitore di uno qualsiasi dei servizi offerti

attività

l'iscrizione ad un corso scuola o l'abbonamento al nuoto libero; ogni socio può avere più attività

corso scuola

corso strutturato in un certo numero di lezioni sopra diversi turni; richiede un'iscrizione, ha una data di inizio ed una di fine

corso libero

corso non strutturato, privo di data di inizio o fine; può essere ripetuto a diverse ore e in diversi giorni; è necessario solo un abbonamento per la frequenza

turno

insieme delle lezioni di un corso scuola o corso libero su base settimanale; per i corsi scuola indica i giorni ed i rispettivi orari che l'utente ha scelto per la frequenza.

VPM® - Visual Pool Manager
© 2000-2009 Simone Zanella Productions
Tutti i diritti riservati.


Il pannello di controllo principale

L'immagine mostra il pannello di controllo principale di VPM. Tutte le funzioni in Visual Pool Manager sono organizzate sotto forma di menu ad albero gerarchico, per permettere di ottenere una classificazione razionale delle funzioni e quindi agevolare l'utente nella ricerca di ciò di cui ha bisogno. Le classi di funzioni (cioè i nodi che contengono più funzioni) presentano un simbolo '+' quando sono chiuse e un simbolo '-' quando sono aperte; è sufficiente un singolo click del mouse o la pressione del tasto enter per aprire e chiudure una classe di funzioni.

L'albero delle funzioni è navigabile attraverso tastiera o mouse.

Le tre principali classi di funzioni sono la Gestione (rappresentata da una mano), le Stampe (rappresentate da una stampante) e la Manutenzione (rappresentata da una cartella con gli attrezzi).

La disposizione degli elementi prevede una fascia di menu con tre voci (File, Strumenti, ?), il pulsante di chiusura e l'albero delle funzioni.

L'interazione con i vari strumenti della finestra è stata studiata per garantire la massima produttività e permettere di svolgere tutte le operazioni da tastiera, oltre che da mouse. Come in tutti i programmi per Windows, è possibile utilizzare la tabulazione per passare da un controllo al successivo, oppure digitare la lettera che si trova sottolineata nel nome dei vari comandi, in combinazione con il tasto Alt. Soffermando per qualche istante il cursore del mouse sopra ciascun controllo comparirà un breve testo descrittivo (tooltip) che illustra la sua funzione.


Impostazione della data e dell'ora

Poiché il comportamento e alcuni degli automatismi di Visual Pool Manager agiscono in base alla data/ora di sistema, all'avvio viene richiesto all'utente di confermare o impostare la data e l'ora corrette. Se necessario, premere il pulsante Modifica e introdurre i valori corretti, oppure premere il pulsante Conferma per accettare i valori proposti. In ogni caso, VPM avvertirà l'utente qualora rilevi che la data attuale è anteriore alla data nella quale l'applicativo è stato avviato l'ultima volta. Avendo correttamente configurato il nome del server nelle impostazioni, la data e l'ora saranno acquisite automaticamente dal server.


Gestione Soci, Iscrizioni, Abbonamenti

Con questa funzione è possibile inserire o modificare i dati dei soci, iscrivere un socio ad un corso scuola oppure abbonarlo ad un corso libero. Digitare il codice del socio, oppure leggerlo attraverso lo scanner, oppure premere il pulsante "Badge" e leggere il suo tag, o ancora introdurre nel campo Cognome/nome una parte della ragione sociale del socio.Se esiste un solo socio che soddisfa quanto introdotto, verranno importati i suoi dati e sarà possibile modificarli; se vi sono più soci corrispondenti, si aprirà una nuova finestra con la lista dei soci trovati da cui scegliere quello da modificare. Inoltre, nel campo cognome/nome sono ammesse wild-card "*", che permettono di sostituire un gruppo di lettere qualsiasi. Ad esempio "*SIM*" troverà tutti i soci che contengono le lettere "SIM" all'interno del nome o del cognome. Nel campo codice, non è necessario digitare gli zeri iniziali. Premendo il pulsante Nuovo dopo aver introdotto un nuovo nome di socio verrà creata una nuova scheda, in cui sarà possibile introdurre i vari dati.

Se il socio esiste già, alla selezione sarà possibile utilizzare il tasto Elimina per rimuovere la sua scheda e tutte le attività collegate. La rimozione di un socio comporta l'aggiornamento delle disponibilità per tutti i corsi scuola ai quali è iscritto.

Il pulsante Ricerca avanzata permette di cercare un socio per corso/turno, numero di telefono oppure città/indirizzo.

Se si specifica il campo Codice Fiscale, il programma ne controllerà la correttezza, avvertendo l'utente in caso contrario.

I dati presenti sono:

  • indirizzo;
  • CAP;
  • Città;
  • Provincia;
  • Telefono;
  • Nato il;
  • Località;
  • Codice fiscale;
  • Sesso;
  • Data prima iscrizione;
  • Livello tecnico;
  • Quota di iscrizione versata;
  • Data di iscrizione;
  • Scadenza;
  • Totale versato;
  • Crediti (importo accreditato per lezioni saltate);
  • Note (il campo si espande all'ingresso e si riduce all'uscita);
  • Ultima frequenza;- Badge principale e badge accompagnatori.

Tutti i campi sono opzionali.

Fare click sull'immagine di un badge per associare il valore del tag che sarà successivamente letto al badge selezionato; i badge "A1" e "A2" indicano gli accompagnatori, cioé utenti che avranno accesso alla vasca negli stessi orari in cui il socio ha delle attività in corso - un accompagnatore può entrare solo dopo che il socio avente diritto all'ingresso è entrato.

Al salvataggio di un nuovo socio, sarà richiesto se si desidera iscriverlo; in questo caso, se abilitato, sarà emesso lo scontrino ed aggiornato l'importo versato dal socio ed il totale progressivo; se si tratta di prima iscrizione, sarà automaticamente aggiornata anche la data corrispondente nel modulo.

Se l'iscrizione di un socio risulta scaduta, all'apertura della scheda sarà possibile specificare il rinnovo, oppure far cessare la domanda le volte successive che si apre la scheda. In ogni caso, se l'iscrizione è scaduta è possibile successivamente premere il pulsante Iscrivi che compare accanto alla data di scadenza. Si noti che, nel caso in cui si disabiliti la richiesta di iscrizione per il socio, viene impostata dal computer la data particolare del "01/01/91" come scadenza; modificare questa data per far comparire di nuovo la richiesta di iscrizione per il socio.

Le iscrizioni dei soci finiscono sempre nel registro di default (fuori da A-E).

Il livello tecnico specificato agisce da filtro per la visualizzazione dei corsi adatti, in fase di iscrizione; più alto è il valore, maggiore è la competenza tecnica dell'utente. Pertanto, saranno adatti tutti i corsi aventi livello minore o uguale a quello specificato; qualora il livello tecnico sia lasciato a 0, l'utente sarà considerato adatto a tutti i corsi.

Premere il pulsante con l'immagine del codice a barre per produrre sulla stampante per codici a barre collegata l'etichetta con il codice del socio.

Il campo "Crediti" viene automaticamente aggiornato quando un operatore accredita una lezione saltata ad un socio, e viene automaticamente utilizzato quando un socio acquista delle lezioni oppure un abbonamento.

Premendo il pulsante Attività verrà salvata la scheda (se il socio è nuovo) e comparirà la lista delle attività alle quali il socio è attualmente iscritto; ogni riga può avere tre colori: verde (regolare), gialla (scaduta), rossa (il socio deve dei soldi).

Selezionare un'attività e premere Modifica per cambiare alcuni dati o Elimina per rimuoverla.

Premendo il pulsante Nuova comparirà una nuova schermata:

In alto è possibile specificare se il socio desidera iscriversi ad un corso scuola o sottoscrivere un abbonamento ad un corso libero. Inoltre, si può specificare se visualizzare solo i corsi adatti oppure tutti i corsi ed infine il criterio di ordinamento (disponibilità, nome corso, data di inizio corso). I campi visualizzati nelle varie tabelle possono essere allargati o ristretti a piacimento agendo con il mouse sulle intestazioni. Nel caso in cui le variazioni apportate non risultino soddisfacenti o comunque si desideri ripristinare le larghezze iniziali, premere il pulsantino rosso alla sinistra dei titoli della tabella.

I corsi ed i rispettivi turni sono rappresentati in verde qualora la disponibilità sia superiore al 50%, in giallo se è compresa tra il 51% e l'80%, in rosso altrimenti.

Selezionando un corso verrà visualizzata la lista dei rispettivi turni; scegliendo un turno, compariranno i rispettivi orari. L'operatore può introdurre tutti gli orari visualizzati premendo il pulsante con la doppia freccia, oppure il solo orario evidenziato premendo il pulsante con la freccia singola. Il pulsante con la "X" bianca su cerchio rosso permette di eliminare il singolo orario evidenziato, il cestino elimina tutti gli orari introdotti. Gli orari possono essere selezionati anche da più turni.

Completata la selezione del corso, premere il pulsante Continua. Si aprirà una nuova finestra, simile a quella che compare premendo inizialmente il pulsante Modifica.

In questa finestra sono riportati corso, turno e orari selezionati, la data di iscrizione, l'importo e la data dell'ultimo versamento, la data di scadenza, il numero di lezioni pagate e frequentate, il totale dovuto (calcolato in base al numero di lezioni fino alla data di scadenza, esclusi i giorni non-lavorativi in archivio), il totale versato e le note.

Nel caso di modifica di un'attività esistente (solo corso scuola), ogni lezione è seguita da "P" se il socio vi ha preso parte oppure da "A" se è stato assente; con un doppio click sull'orario della lezione è possibile sostituire l'orario con un'altro (scelto da uno qualsiasi dei turni) oppure accreditare la lezione.

La casella di spunta Registra pagamento di può essere abilitata per registrare l'importo corrispondente nei progressivi, suddiviso in quota sociale e prestazionale in base alle impostazioni del corso; al salvataggio, l'importo introdotto è sottratto dall'importo dovuto. Nel caso sia abilitata la richiesta operatore (vedi le Impostazioni), sarà necessario selezionare l'operatore prima di completare la registrazione.


Gestione Prenotazioni Corsi Liberi

Con questa funzione è possibile inserire una prenotazione per un corso libero. Nella parte alta del modulo è possibile scegliere tra socio e non socio; la ricerca avviene in modo simile a quanto visto nella Gestione Soci, con la possibilità di specificare anche un socio la cui anagrafica non è presente in archivio. Una volta selezionato un socio, è necessario utilizzare il pulsante "Cambia" per abilitare la scelta di un'altra persona.

Premere le immagini dei badge per effettuare la lettura di un tag RF; i badge che vengono temporaneamente associati con questa funzione scadono non appena vengono letti e devono essere restituiti dal socio all'uscita.

Al centro della scheda si trova una casella a scelta con i corsi liberi e due campi nei quali è possibile introdurre la data di inizio e fine del periodo da considerare; il pulsante Visualizza riempirà la parte bassa della scheda con i dati trovati corrispondenti a quanto specificato.

I turni e orari trovati saranno rappresentati con il consueto codice colore (verde se la disponibilità è superiore al 50%, giallo se è compresa tra il 50 e l'80%, rosso altrimenti); anche in questo caso è possibile ridimensionare le varie colonne agendo sull'intestazione e ripristinare la larghezza di default agendo sul pulsantino rosso a sinistra della tabella. Selezionare una voce dalla tabella degli orari. Premendo il pulsante Registra sarà registrato l'importo (suddiviso in quota sociale e prestazionale opportunamente) e verrà chiesta conferma per la stampa della ricevuta (e/o dello scontrino, se abilitati). Nel caso sia abilitata la richiesta operatore (vedi le Impostazioni), sarà necessario selezionare anche l'operatore prima di completare la registrazione.


Gestione Corsi

Con questa funzione è possibile introdurre, modificare, cancellare o attivare uno o più corsi.

Premere il pulsante Nuovo per creare un nuovo corso; i dati richiesti sono abbastanza auto-esplicativi. Ogni corso deve avere un nome ed una sigla distinti. I corsi si distinguono in corsi scuola (strutturati in un certo numero di lezioni, con un inizio e una fine) e corsi liberi (che non hanno un inizio e una fine). Ogni corso sarà caratterizzato da una vasca predefinita in cui si svolgerà; inoltre, è possibile specificare degli sbarramenti alla frequenza, indicando un livello tecnico minimo, una età minima e massima e la classe (femminile, maschile o mista) per i partecipanti. Lasciando i primi due dati a 0 ed il terzo a "Mista" non sussisterà alcun vincolo. I corsi scuola richiedono poi un numero di lezioni ed il costo unitario, mentre i corsi liberi richiedono la durata dell'abbonamento (in giorni) e hanno fino a quattro classi di costo (in base al numero di lezioni acquistate contestualmente) ed un costo separato per la vendita di un ingresso singolo; il flag "Controlla ora ingresso", se non selezionato, permette l'ingresso in qualsiasi momento; se invece è selezionato il socio potrà entrare solo nell'orario previsto (a meno della tolleranza). Per entrambi i tipi di corso è richiesta la ripartizione tra quota sociale e prestazionale dell'importo versato; il registro indica il totale di pertinenza per il calcolo delle somme delle quote sociali e prestazionali - può essere vuoto (default) oppure una lettera compresa tra A ed E.

Premendo il pulsante Salva sarà verificata la consistenza dei dati introdotti e saranno memorizzati i dati del corso.

Per modificare un corso, selezionarlo dalla casella a scelta in alto e premere il pulsante Modifica. Non è possibile variare il tipo di corso (scuola o libero) per un corso già inserito.

Un corso inserito può essere successivamente attivato, indicando una data iniziale e finale (corso libero) oppure una data iniziale ed il numero di lezioni (corso scuola). VPM proporrà una lista di date/orari dedotte dai turni definiti per il turno, che l'operatore potrà comunque variare a piacimento.

I corsi attivati possono essere modificati in qualunque momento, sebbene per i corsi scuola non sia possibile eliminare una data, ma solo cambiarla. Si presti particolare attenzione alla cancellazione dei corsi e dei corsi attivati, in quanto si perderanno tutte le iscrizioni collegate dei clienti.

Il pulsante Turni permette di aggiungere, modificare o cancellare i turni collegati ad un corso. Un turno rappresenta un aggregato di lezioni su diversi giorni della settimana e con diversi orari. Una volta selezionata la funzione comparirà un modulo simile al seguente:

Premere il pulsante Nuovo per introdurre un nuovo turno, Elimina per cancellarlo, Modifica per cambiarne il nome.

Per modificare gli orari di un turno, premere il pulsante Orari; si abiliterà la modifica della metà bassa del modulo e sarà possibile selezionare:

  • vasca in cui si svolgerà la lezione;
  • ora di inizio;
  • ora di fine;
  • giorno della settimana.

Mediante la freccia orientata verso destra si introdurrà l'orario nel giorno selezionato, mentre la freccia verso sinistra permetterà di rimuovere l'orario selezionato dal pannello sulla destra.

Premere il tasto Fine per completare le modifiche agli orari ed il tasto Chiudi per uscire dall'opzione.

Questa funzione, data la sua importanza e delicatezza, nel caso di sistema multi-utente è riservata alla postazione primaria.


Gestione Calendario

Con questa funzione è possibile introdurre o eliminare dei giorni di chiusura attività; i giorni introdotti non verranno considerati nel calcolo delle lezioni per i corsi scuola e per gli abbonamenti ai corsi liberi.

Premere il pulsante Nuovo per introdurre un nuovo giorno di chiusura o selezionare un giorno introdotto e premere il pulsante Elimina.

I giorni di chiusura trascorsi sono automaticamente rimossi.

Questa funzione, data la sua importanza e delicatezza, nel caso di sistema multi-utente è riservata alla postazione primaria.


Gestione Vasche

Con questa funzione è possibile introdurre, modificare o eliminare le vasche amministrate dal programma.

Premere il pulsante Nuova per introdurre una nuova vasca. I dati da introdurre sono largamente autoesplicativi.

Selezionare dalla casella a scelta la vasca da modificare e premere il pulsante Modifica per apportare delle variazioni ai dati di una vasca esistente.

Premere il pulsante Elimina per cancellare una vasca selezionata. ATTENZIONE: La rimozione di una vasca causa anche la rimozione di tutti i corsi associati, a catena.

Questa funzione, data la sua importanza e delicatezza, nel caso di sistema multi-utente è riservata alla postazione primaria.


Stato in tempo reale

Con questa funzione è possibile monitorare costantemente lo stato delle vasche: i soci presenti, le attività in corso, i ritardatari della giornata, eventuali anomalie che si fossero verificate (ingressi doppi, uscite senza ingresso, badge sconosciuti) gli incassi e la loro ripartizione. La vista viene automaticamente aggiornata ogni 60 secondi circa, oppure quando si preme il pulsante Aggiorna.

Questa funzione, per la tipologia di dati visualizzati, nel caso di sistema multi-utente è riservata alla postazione primaria.


Quote incassate su periodo e frequenze

Con questa funzione è possibile visualizzare e stampare le quote incassate su di un certo periodo e le utenze registrate.

Introdurre le date corrispondenti agli estremi del periodo e premere il pulsante Conferma.

Nella tabella sottostante saranno visualizzate le date per le quali esistono delle registrazioni in archivio, accompagnate dalle quote sociali/prestazional incassate in ciascun registro e dalle relative utenze.

Come al solito, è possibile variare la dimensione delle colonne agendo sulle intestazioni e ripristinare le dimensioni di default premendo il pulsantino rosso in alto a sinistra.

Sotto la tabella sarà riportato un consuntivo dei dati visualizzati.

Per ottenere un documento stampabile, premere il pulsante Report; sarà avviato il browser di default impostato in configurazione e generato un documento HTML contenente i medesimi dati. Il formato del report dipenderà dalla casella Report semplificato delle Impostazioni. Utilizzare i comandi di stampa del proprio browser per ottenere una rappresentazione cartacea del documento.

Il pulsante Grafico permette di ottenere una rappresentazione ad istogramma dei dati visualizzati; il tipo di grafico ottenuto è influenzato dalle seguenti impostazioni:

  • solo consuntivo;
  • aggrega registri;
  • confronta con.

Il primo parametro permette di ottenere un grafico con i soli totali, senza il dettaglio giornaliero.

Selezionando la casella di controllo relativa al secondo parametro tutti i registri compariranno su di un'unica colonna. Il terzo parametro permette di confrontare i soli consuntivi del primo periodo specificato con quelli del secondo periodo.

Questa funzione, per la tipologia di dati visualizzati, nel caso di sistema multi-utente è riservata alla postazione primaria.


Riepiloghi giornalieri

Con questa funzione è possibile visualizzare e stampare i riepiloghi giornalieri su di un certo periodo. I dati dei riepiloghi sono automaticamente eliminati quando superano i 31 giorni di permanenza in archivio.

Introdurre le date corrispondenti agli estremi del periodo e premere il pulsante Conferma.

Nella tabella sottostante saranno visualizzate le date per le quali esistono delle registrazioni, accompagnate dagli importi, dal tipo operazione, dall'operatore e dal socio.

Come al solito, è possibile variare la dimensione delle colonne agendo sulle intestazioni e ripristinare le dimensioni di default premendo il pulsantino rosso in alto a sinistra.

Sotto la tabella sarà riportato un consuntivo dei dati visualizzati.

Per ottenere un documento stampabile, premere il pulsante Report; sarà avviato il browser di default impostato in configurazione e generato un documento HTML contenente i medesimi dati. Il formato del report dipenderà dalla casella Report semplificato delle Impostazioni. Utilizzare i comandi di stampa del proprio browser per ottenere una rappresentazione cartacea del documento.

Questa funzione, per la tipologia di dati visualizzati, nel caso di sistema multi-utente è riservata alla postazione primaria.


Riepiloghi settimanali ingressi

Con questa funzione è possibile visualizzare e stampare un riepilogo settimanale degli ingressi, relativo ad una specifica settimana.

Introdurre una data appartenente alla settimana da analizzare e premere il pulsante Conferma; sarà avviato il browser di default impostato in configurazione e generato un documento HTML contenente il numero di ingressi suddiviso in fasce orarie; per ogni fascia, sarà visualizzato il totale degli ingressi e la suddivisione nei vari corsi. Le fasce orarie sono determinate dai valori di ORAINIZIALE e MINSTEP nel file ingressi.prt.

Il formato del report dipenderà dalla casella Report semplificato delle Impostazioni. Utilizzare i comandi di stampa del proprio browser per ottenere una rappresentazione cartacea del documento.

Questa funzione, per la tipologia di dati visualizzati, nel caso di sistema multi-utente è riservata alla postazione primaria.


Disponibilità corsi scuola

Con questa funzione è possibile visualizzare e stampare le disponibilità attuali dei corsi scuola.

All'ingresso della funzione, sarà richiesto di scegliere una data di riferimento a partire dalla quale considerare i corsi attivati (di default è impostata a 60 giorni prima della data di sistema).

Selezionare un corso dalla lista; nel modulo in basso compariranno il numero iscritti, i posti disponibili ed i posti totali.

Per ottenere un documento stampabile, premere il pulsante Report; sarà avviato il browser di default impostato in configurazione e generato un documento HTML contenente i medesimi dati posti in forma tabellare. Il formato del report dipenderà dalla casella Report semplificato delle Impostazioni. Utilizzare i comandi di stampa del proprio browser per ottenere una rappresentazione cartacea del documento.


Lista iscritti a corso/turno

Con questa funzione è possibile visualizzare e stampare la lista degli iscritti ad un certo turno di un corso scuola.

All'ingresso della funzione, sarà richiesto di scegliere una data di riferimento a partire dalla quale considerare i corsi attivati (di default è impostata a 60 giorni prima della data di sistema).

Selezionare dalle tre caselle a scelta il corso, il turno e l'orario desiderati e premere il pulsante Conferma.

Nella tabella sottostante saranno visualizzati codice, cognome e nome, età dei soci attualmente iscritti al corso/turno selezionato, mentre sulla destra comparirà il dettaglio degli orari del turno.

Come al solito, è possibile variare la dimensione delle colonne agendo sulle intestazioni e ripristinare le dimensioni di default premendo il pulsantino rosso in alto a sinistra.

Sotto la tabella sarà riportato un consuntivo dei dati visualizzati.

Per ottenere un documento stampabile, premere il pulsante Report; sarà avviato il browser di default impostato in configurazione e generato un documento HTML contenente i medesimi dati. Il formato del report dipenderà dalla casella Report semplificato delle Impostazioni. Utilizzare i comandi di stampa del proprio browser per ottenere una rappresentazione cartacea del documento.


Lista corsi scuola/turni

Con questa funzione è possibile visualizzare la distribuzione su scala settimanale di tutti i turni dei corsi scuola attivi.

Introdurre le date corrispondenti agli estremi del periodo e premere il pulsante Conferma. Saranno considerati solo i corsi attivi che iniziano e terminano nel periodo introdotto.

Nella tabella saranno visualizzati le ore, i nomi dei corsi e dei turni per ciascun giorno della settimana.

Come al solito, è possibile variare la dimensione delle colonne agendo sulle intestazioni e ripristinare le dimensioni di default premendo il pulsantino rosso in alto a sinistra.

Sotto la tabella sarà riportato un consuntivo dei dati visualizzati.

Per ottenere un documento stampabile, premere il pulsante Report; sarà avviato il browser di default impostato in configurazione e generato un documento HTML contenente i medesimi dati. Il formato del report dipenderà dalla casella Report semplificato delle Impostazioni. Utilizzare i comandi di stampa del proprio browser per ottenere una rappresentazione cartacea del documento.


Statistiche sugli iscritti

Con questa funzione è possibile visualizzare la distribuzione su scala settimanale di tutti gli iscritti che frequentano una certa vasca (al momento della richiesta).

Selezionare la vasca e premere il pulsante Conferma.

Nella lista saranno elencate tutte le statistiche memorizzate per quella vasca, con la data e l'ora della richiesta e la data di riferimento. Premendo il pulsante Nuova verrà creata una nuova statistica con le informazioni attualmente presenti nell'archivio; saranno considerati solo i corsi attivi per i quali la data di riferimento risulta all'interno del periodo tra l'inizio e la fine del corso.

Il pulsante Elimina permetterà di cancellare la statistica selezionata, mentre il pulsante Annulla consentirà di selezionare un'altra vasca od uscire.

Per ottenere un documento stampabile, premere il pulsante Visualizza; sarà avviato il browser di default impostato in configurazione e generato un documento HTML contenente una tabella che evidenzia, per ogni giorno/ora della settimana, il numero degli iscritti che frequentano la vasca.

Il formato del report dipenderà dalla casella Report semplificato delle Impostazioni. Utilizzare i comandi di stampa del proprio browser per ottenere una rappresentazione cartacea del documento.


Soci con attività esaurite di recente

Con questa funzione è possibile visualizzare e stampare un elenco dei soci che hanno esaurito un'attività all'interno di un periodo specificato.

Introdurre le date corrispondenti agli estremi del periodo e premere il pulsante Conferma.

Nella tabella sottostante saranno visualizzati i dati dei soci corrispondenti.

Come al solito, è possibile variare la dimensione delle colonne agendo sulle intestazioni e ripristinare le dimensioni di default premendo il pulsantino rosso in alto a sinistra.

Sotto la tabella sarà riportato un consuntivo dei dati visualizzati.

Per ottenere un documento stampabile, premere il pulsante Report; sarà avviato il browser di default impostato in configurazione e generato un documento HTML contenente i medesimi dati. Il formato del report dipenderà dalla casella Report semplificato delle Impostazioni. Utilizzare i comandi di stampa del proprio browser per ottenere una rappresentazione cartacea del documento.


Soci con iscrizione scaduta

Con questa funzione è possibile visualizzare e stampare un elenco dei soci non iscritti oppure la cui iscrizione è scaduta all'interno di un periodo specificato.

Introdurre le date corrispondenti agli estremi del periodo oppure selezionare la casella di spunta Non iscritti e premere il pulsante Conferma.

Nella tabella sottostante saranno visualizzati i dati dei soci corrispondenti.

Come al solito, è possibile variare la dimensione delle colonne agendo sulle intestazioni e ripristinare le dimensioni di default premendo il pulsantino rosso in alto a sinistra.

Sotto la tabella sarà riportato un consuntivo dei dati visualizzati.

Per ottenere un documento stampabile, premere il pulsante Report; sarà avviato il browser di default impostato in configurazione e generato un documento HTML contenente i medesimi dati. Il formato del report dipenderà dalla casella Report semplificato delle Impostazioni. Utilizzare i comandi di stampa del proprio browser per ottenere una rappresentazione cartacea del documento.


Soci insolventi

Con questa funzione è possibile visualizzare la lista dei soci insolventi.

Nella tabella saranno visualizzati il codice, il cognome e nome, il telefono, l'età, l'attività alla quale si riferisce l'insolvenza e l'importo dovuto.

Come al solito, è possibile variare la dimensione delle colonne agendo sulle intestazioni e ripristinare le dimensioni di default premendo il pulsantino rosso in alto a sinistra.

Sotto la tabella sarà riportato un consuntivo dei dati visualizzati.

Per ottenere un documento stampabile, premere il pulsante Report; sarà avviato il browser di default impostato in configurazione e generato un documento HTML contenente i medesimi dati. Il formato del report dipenderà dalla casella Report semplificato delle Impostazioni. Utilizzare i comandi di stampa del proprio browser per ottenere una rappresentazione cartacea del documento.


Storico iscrizioni

Soci iscritti per periodo

Con questa funzione è possibile visualizzare e stampare i soci che si sono iscritti in un certo intervallo di tempo e le relative quote di iscrizione incassate.

Introdurre le date corrispondenti agli estremi del periodo e premere il pulsante Conferma.

Nella tabella sottostante saranno visualizzati i soci iscritti nel periodo considerato, accompagnati dai loro dati personali e dall'importo della quota versata.

Come al solito, è possibile variare la dimensione delle colonne agendo sulle intestazioni e ripristinare le dimensioni di default premendo il pulsantino rosso in alto a sinistra.

Sotto la tabella sarà riportato un consuntivo dei dati visualizzati.

Per ottenere un documento stampabile, premere il pulsante Report; sarà avviato il browser di default impostato in configurazione e generato un documento HTML contenente i medesimi dati. Il formato del report dipenderà dalla casella Report semplificato delle Impostazioni. Utilizzare i comandi di stampa del proprio browser per ottenere una rappresentazione cartacea del documento.


Soci iscritti per data di nascita

Con questa funzione è possibile visualizzare e stampare i soci iscritti in base alla loro data di nascita.

Introdurre giorno e mese degli estremi del periodo e premere il pulsante Conferma.

Nella tabella sottostante saranno visualizzati i soci iscritti nel periodo considerato, accompagnati dai loro dati personali e dalla data di prima iscrizione.

Come al solito, è possibile variare la dimensione delle colonne agendo sulle intestazioni e ripristinare le dimensioni di default premendo il pulsantino rosso in alto a sinistra.

Sotto la tabella sarà riportato un consuntivo dei dati visualizzati.

Per ottenere un documento stampabile, premere il pulsante Report; sarà avviato il browser di default impostato in configurazione e generato un documento HTML contenente i medesimi dati. Il formato del report dipenderà dalla casella Report semplificato delle Impostazioni. Utilizzare i comandi di stampa del proprio browser per ottenere una rappresentazione cartacea del documento.


Eliminazione giornalieri

Con questa funzione è possibile eliminare tutte le registrazioni relative ai dati giornalieri su di un periodo specificato.

Introdurre le date corrispondenti agli estremi del periodo (pre-calcolate in base ai valori delle Impostazioni) e premere il pulsante Conferma.

Sarà visualizzato un consuntivo delle registrazioni che verrebbero rimosse.

Premere il pulsante Rimuovi per confermare la cancellazione, Annulla per abortire l'operazione.

Ricordiamo che i giornalieri contengono, giorno per giorno, lo storico delle frequenze suddivise per corso/turno.

Questa funzione, data la sua importanza e delicatezza, nel caso di sistema multi-utente è riservata alla postazione primaria.


Azzeramento totali versati

Con questa funzione è possibile impostare a 0 il totale versato per tutti i soci in archivio.

Dopo averla selezionata, è necessario dare una doppia conferma, in quanto questa funzione ha un effetto globale non reversibile.

Questa funzione, data la sua importanza e delicatezza, nel caso di sistema multi-utente è riservata alla postazione primaria.


Copia/ripristino archivi

Con questa funzione è possibile effettuare una copia di sicurezza (backup) degli archivi del programma oppure ripristinarli (restore) da una copia esistente.

Selezionare l'operazione che si desidera effettuare; premere il pulsante Cambia per modificare il percorso di lettura/salvataggio; premere il pulsante Salva per effettuare la copia di sicurezza, oppure Ripristina per effettuare l'operazione inversa.

Per l'operazione di ripristino è necessario dare una doppia conferma, in quanto questa funzione ha un effetto globale non reversibile.

Il file risultante dal salvataggio è il file pool.mdb.zl (compresso); è necessario, pertanto, utilizzare Visual Pool Manager per ripristinarlo.

Si raccomanda sempre di effettuare un salvataggio con frequenza giornaliera dei dati, alternando almeno due set di dischi, e di mantenere le copie di sicurezza in un luogo diverso da quello in cui si trova installato il programma.

Questa funzione, data la sua importanza e delicatezza, nel caso di sistema multi-utente è riservata alla postazione primaria e richiede che tutte le altre postazioni siano CHIUSE (cioè non vi sia un'altra copia di VPM in esecuzione sullo stesso archivio dati).


Compattamento/riparazione archivi

Con questa funzione è possibile compattare e riparare la base di dati utilizzata dal programma.

Prima di procedere con questa opzione, è altamente raccomandata la copia di sicurezza degli archivi, per ripristinare la copia precedente qualora questa operazione non andasse a buon fine.

Dopo averla selezionata, è necessario dare una doppia conferma, in quanto questa funzione ha un effetto globale non reversibile.

Si raccomanda di eseguire questa funzione con frequenza settimanale, per minimizzare la dimensione degli archivi e mantenere elevate le prestazioni del sistema.

Questa funzione, data la sua importanza e delicatezza, nel caso di sistema multi-utente è riservata alla postazione primaria e richiede che tutte le altre postazioni siano CHIUSE (cioè non vi sia un'altra copia di VPM in esecuzione sullo stesso archivio dati).


Eliminazione progressivi

Con questa funzione è possibile eliminare tutte le registrazioni relative ai dati progressivi su di un periodo specificato.

Introdurre le date corrispondenti agli estremi del periodo (pre-calcolate in base ai valori delle Impostazioni) e premere il pulsante Conferma.

Sarà visualizzato un consuntivo delle registrazioni che verrebbero rimosse.

Premere il pulsante Rimuovi per confermare la cancellazione, Annulla per abortire l'operazione.

Ricordiamo che i progressivi contengono, giorno per giorno, gli incassi suddivisi per quota sociale/prestazionale nei registri e le utenze.

Questa funzione, data la sua importanza e delicatezza, nel caso di sistema multi-utente è riservata alla postazione primaria.


Impostazione default e stampanti

Con questa funzione è possibile impostare i parametri fondamentali di funzionamento di Visual Pool Manager: stampanti, report, ricevute, quote, operatori, tag RF.

La finestra di configurazione è suddivisa in sei schede, la prima delle quali è rappresentata più sopra; alcuni parametri sono accessibili e modificabili solo dalla postazione primaria.

Questa prima scheda contiene i parametri di funzionamento per la stampante per codici a barre, utilizzata per produrre i barcode dei soci. I parametri di comunicazione seriale di default sono: COM1, 9600 baud, 8 data bits, parity None, 1 stop bits. Il programma viene fornito conuno spool di default (bcspool.txt, nella cartella di installazione dell'applicativo) che funziona per produrre etichette di formato 67 mm x 37 mm su una stampante Eltron TLP 2742.

La seconda scheda permette di specificare se il report utilizzato dalle funzioni di stampa è la versione normale (modello.html) o semplificata (modello_white.html) e il percorso del browser per la visualizzazione della pagina html generata; sotto Windows NT/2000/XP/2003/Vista, quest'ultimo si può scrivere come "CMD /C START".

La terza scheda permette di specificare la porta parallela della stampante per le ricevute ed il numero della ricevuta corrente, la porta per il registratore di cassa e se includere o meno la quota sociale/prestazionale nelle ricevute/scontrini. Le caselle "Conferma stampa" permettono di specificare se richiedere o meno conferma per procedere alla stampa della ricevuta/scontrino. Il programma viene fornito con uno spool di default (ricspool.txt, nella cartella di installazione dell'applicativo) che funziona per produrre ricevute su una stampante Epson LQ-300 (altezza 93 mm). Utilizzare il campo "Numero ricevuta" per cambiare la numerazione delle ricevute emesse; in particolare, questo campo andrebbe re-impostato a 1 all'inizio di ogni nuovo anno. Il registratore di cassa supportato è il modello RCH G350, che deve essere configurato a 9600 baud, parità Even, 7 bit di dati, 1 bit di stop, oppure un registratore di cassa con protocollo Sarema (9600 baud, parità None, 8 bit di dati, 1 bit di stop).

La quarta scheda permette di specificare l'importo della quota di iscrizione (che finirà nella quota sociale), la durata della quota prestazionale, la durata di default dell'abbonamento ai corsi liberi, la ripartizione standard tra quota sociale e prestazionale.

La quinta scheda permette di aggiungere, modificare o eliminare gli operatori e se richiedere o meno l'operatore prima di ciascuna operazione di versamento. Non è possibile introdurre due operatori omonimi. L'eliminazione di un operatore comporterà l'eliminazione di tutte le registrazioni nei riepiloghi relative allo stesso operatore. Ogni operazione verrà effettuata immediatamente (al contrario delle altre impostazioni, che richiedono di premere OK per salvare le modifiche effettuate).

La sesta scheda permette di specificare il numero massimo di giorni che possono trascorrere per il recupero automatico di una lezione saltata di un corso scuola. Sempre in questa scheda si indica la porta seriale alla quale è collegato il lettore di tag RF (9600 baud, parità None, 8 bit di dati, 1 bit di stop) ed i badge degli operatori, denominati "skeleton key" (comunelle). Premere "Nuovo" per aggiungere un badge: vi sarà richiesto di passarlo sul lettore e dovrete successivamente introdurre una data di scadenza ed una descrizione mnemonica (es. l'operatore assegnatario). Premere Elimina per rimuovere una skeleton key precedentemente aggiunta.

La cornice Chiosco permette di impostare la porta alla quale è collegato il lettore di tag sul chiosco ed il tempo di visualizzazione in secondi di ciascuna attività del socio.


Iscrizione totale

Con questa funzione è possibile iscrivere tutti i soci ad una certa data, con l'eventuale esclusione dei soci già regolarmente iscritti. Digitare la data, modificare il valore della casella di spunta Considera solo i soci con iscrizione scaduta (se necessario) e premere il pulsante Conferma. Dopo aver confermato, è necessario rispondere affermativamente, in quanto questa funzione ha un effetto globale non reversibile.

Questa funzione, data la sua importanza e delicatezza, nel caso di sistema multi-utente è riservata alla postazione primaria.


Gestione transiti

Con questa funzione è possibile visualizzare e rimuovere i transiti, i movimenti sulle attività, le frequenze dei soci, nonché far uscire un socio qualora (per un temporaneo fermo dell'impianto) non sia stata registrata la sua uscita.

La finestra è suddivisa in quattro schede, la prima delle quali è rappresentata più sopra.

Questa prima scheda permette di ottenere la lista dei transiti avvenuti fra le date/ore specificate; è possibile selezionare un particolare tornello, il tipo di transito (ingresso/uscita), il risultato e la motivazione con la quale il transito è stato negato o autorizzato. Premendo Conferma saranno estratte le registrazioni pertinenti, che potranno essere rimosse premendo Cancella; il tasto Modifica consente di cambiare il criterio di estrazione.

La seconda scheda permette di ottenere la lista dei movimenti sulle attività avvenuti fra le date/ore specificate; è anche possibile specificare un particolare evento. Premendo Conferma saranno estratte le registrazioni pertinenti, che potranno essere rimosse premendo Cancella; il tasto Modifica consente di cambiare il criterio di estrazione.

La terza scheda permette di ottenere la lista dei soci attualmente in vasca, con le date/ore di ingresso e di uscita prevista; selezionare un socio e premere Cancella per farlo uscire manualmente, qualora per un fermo dell'impianto non sia stata registrata la sua uscita.

La quarta scheda permette di ottenere la lista delle frequenze avvenute fra le date/ore specificate; è possibile specificare lo stato (presente/assente, lezione recuperata o meno), nonché la puntualità o meno all'uscita. Premendo Conferma saranno estratte le registrazioni pertinenti, che potranno essere rimosse premendo Cancella; il tasto Modifica consente di cambiare il criterio di estrazione.

Questa funzione, data la sua importanza e delicatezza, nel caso di sistema multi-utente è riservata alla postazione primaria.


Menu File

Uscita

Selezionare una delle voci di menu soprastanti per ottenere informazioni sulla relativa funzionalità.


Menu Strumenti

Disponibilità corsi

Vendita ingresso singolo

Registr. manuale ingresso

Selezionare una delle voci di menu soprastanti per ottenere informazioni sulla relativa funzionalità.


Menu Aiuto

Aiuto

Informazioni

Selezionare una delle voci di menu soprastanti per ottenere informazioni sulla relativa funzionalità.


Aiuto

Questo comando richiama la guida che state leggendo.


Disponibilità corsi

Con questa funzione è possibile visualizzare le disponibilità attuali dei corsi scuola e dei corsi liberi.

Selezionare il tipo di attività (corso scuola o libero), l'ordinamento (per disponibilità, nome o data di inizio); scegliere quindi il corso dalla lista sottostante ed il suo turno per ottenere una lista analitica del numero di posti disponibili per ciascuna data/ora. Premere "Chiudi" per uscire.


Esci

Uscita

Utilizzare questo comando per uscire, oppure clickare sul pulsante X in alto a destra, oppure ancora premere il pulsante 'Chiudi'.


Informazioni

Questo comando mostra le informazioni sulla versione corrente, sull'autore del programma e sui copyright.


Registrazione manuale ingresso

Con questa funzione è possibile registrare manualmente un ingresso, qualora per qualsiasi motivo non sia stato possibile effettuare l'ingresso automatico (es. dimenticanza o danneggiamento del badge, ecc).

Selezionare il socio come nella scheda di gestione soci; saranno visualizzate tutte le attività non scadute nella parte sottostante. Scegliere un'attività e premere il pulsante Entra; se l'attività prevede più date/ore si dovrà indicare anche per quale data si registra l'ingresso.

Premere Chiudi per tornare alla selezione del socio, Fine per uscire.


Lista abbonati a corso libero

Con questa funzione è possibile visualizzare e stampare la lista degli abbonati ad un corso libero.

All'ingresso della funzione, sarà richiesto di scegliere una data di riferimento a partire dalla quale considerare i corsi attivati (di default è impostata a 60 giorni prima della data di sistema).

Selezionare dalla casella a scelta il corso desiderato e premere il pulsante Conferma.

Nella tabella sottostante saranno visualizzati codice, cognome e nome, età dei soci attualmente abbonati al corso selezionato.

Come al solito, è possibile variare la dimensione delle colonne agendo sulle intestazioni e ripristinare le dimensioni di default premendo il pulsantino rosso in alto a sinistra.

Sotto la tabella sarà riportato un consuntivo dei dati visualizzati.

Per ottenere un documento stampabile, premere il pulsante Report; sarà avviato il browser di default impostato in configurazione e generato un documento HTML contenente i medesimi dati. Il formato del report dipenderà dalla casella Report semplificato delle Impostazioni. Utilizzare i comandi di stampa del proprio browser per ottenere una rappresentazione cartacea del documento.


Ricerca avanzata

Con questa funzione è possibile specificare il criterio per la ricerca dei soci scegliendo tra:

  • corso e turno;
  • numero di telefono;
  • indirizzo e/o città.

Selezionare quindi il pulsante corrispondente al criterio di ricerca, introdurre i dati richiesti e premere il pulsante Cerca.

Se viene rinvenuto più di un socio corrispondente, comparirà una lista tra cui scegliere.

I campi che richiedono la digitazione di un dato andrebbero sempre completati tenendo presente che è sufficiente specificare un prefisso significativo (di solito) invece che il dato per esteso. Inoltre, nei campi relativi al numero di telefono, all'indirizzo e alla città sono ammesse wild-card "*", che permettono di sostituire un gruppo di lettere qualsiasi. Ad esempio "*NAZ*" nel campo indirizzo troverà tutti gli indirizzi che contengono le lettere "NAZ" al loro interno.